Support Advisories

SpeedLine 7.3 Release 104 now available (Security Fixes)

Posted by SpeedLine Support on Apr 1, 2019 1:49:05 PM

SpeedLine 7.3 Release 104 is available today. This release is PCI affecting for Monetra EMV customers.

  • For Monetra EMV customers: This release will upgrade Monetra Uniterm to the latest security release (9.2.2).
    • SpeedLine customers using Monetra and EMV Pin Pads will need to upgrade within 30 days to ensure they have the most recent security fixes.
  • PCI Requirement 6.2 states: Ensure that all system components and software are protected from known vulnerabilities by installing applicable vendor-supplied security patches. Install critical security patches within one month of release.
  • For more information about PCI, please go to https://www.pcisecuritystandards.org/

  • For all other customers: This release contains no security fixes for non-Monetra EMV customers. Customers are still encouraged to upgrade to take advantage of new features, enhancements, and fixes, but it is not required. See What's New in SpeedLine v7.3 Updates for a summary of what's included.

Release Notes

#19630  New:  Upgraded UniTerm to version 9.2.2
#19706  Changed: Manager alert appears for menu changes made mid-day by the Restricted Mode user.
#19729  Changed:  LiveMaps better handles border locations where Bing returns different information than expected.
#19731  Changed:  Fingerprint sensor drivers rolled back to version 2.2 due to new driver incompatibility issues with older operating systems in certain configurations.


      Request an Upgrade

Request an Upgrade

Topics: SpeedLine Releases, PCI, POS new release, SpeedLine